Bug ID 1289041: APM Modern Customization: A custom icon for the Decision Box fails to render and returns a 404 error."

Last Modified: Sep 08, 2026

Affected Product(s):
BIG-IP APM(all modules)

Known Affected Versions:
16.1.3, 16.1.3.1, 16.1.3.2, 16.1.3.3, 16.1.3.4, 16.1.3.5, 16.1.4, 16.1.4.1, 16.1.4.2, 16.1.4.3, 16.1.5, 16.1.5.1, 16.1.5.2, 16.1.6, 16.1.6.1

Opened: Apr 14, 2023

Severity: 3-Major

Symptoms

When using the Modern Customisation Framework with General Customisation, a custom image configured for the Decision Box fails to render on the access policy page, and a 404 error is returned for the image resource. The Standard Customisation Framework remains unaffected.

Impact

End users accessing a virtual server with a Modern-type Access Profile will not see the configured custom Decision Box icon, as a 404 error is returned for the custom image resource. Standard profile types remain unaffected.

Conditions

This issue occurs when the following conditions are met: - An Access Profile is configured with the profile type set to Modern. - A custom image is assigned to the Decision Box under: Access > Profiles/Policies > Customisation> General > Customisation Settings > Access Profiles > [profile] > Decision Pages > Decision Box > General > Field 1 image.

Workaround

Use a Standard Access Profile type instead of Modern, as custom Decision Box icons render correctly when the Access Profile type is set to Standard.

Fix Information

None

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips