Bug ID 1056037: If any tenant is in a 'deployed' state, you cannot downgrade the partition to version 1.1.4.

Last Modified: Nov 22, 2021

Bug Tracker

Affected Product:  See more info
F5OS Velos(all modules)

Known Affected Versions:
1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.2.1, 1.2.2

Opened: Oct 20, 2021
Severity: 3-Major

Symptoms

An attempt to downgrade partition services to 1.1.4 fails with the error: "Partition database upgrade compatibility check failed." The validation logic in 1.1.4 does not permit tenants to be in the 'deployed' state during the schema change. This logic is a mistake.

Impact

You cannot downgrade partition services for this tenant to 1.1.x from any higher version.

Conditions

Tenant is in a 'deployed' state.

Workaround

1. In the partition manager CLI or UI, change the running-state for the tenant you want to downgrade to 'provisioned'. 2. Perform the downgrade for the tenant. 3. When the downgrade is complete, return the tenant to the 'deployed' state.

Fix Information

None

Behavior Change