Bug ID 430907: When upgrading to 12.1.0 or later, update Cookie Persistence Encryption setting if necessary

Last Modified: Apr 10, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP Install/Upgrade, LTM(all modules)

Fixed In:
12.1.0

Opened: Sep 17, 2013
Severity: 2-Critical

Symptoms

When upgrading a BIG-IP from v12.1.0 to v12.1.0 or later, the Cookie Persistence Encryption setting may be modified as follows: -- If Cookie Persistence Encryption is set to 'Preferred' and a Passphrase is in use, it will be changed to 'Required'. -- If Cookie Persistence Encryption is set to 'Preferred' or 'Required' and a Passphrase is not in use, it will be changed to 'Off'. In the latter case, a warning will be emitted to /var/log/ltm.

Impact

The Cookie Persistence Encryption setting may be modified unexpectedly during an upgrade.

Conditions

Cookie Persistence Encryption in use, and one of the following conditions is true: -- Cookie Persistence Encryption is set to 'Preferred' and a Passphrase is in use. -- Cookie Persistence Encryption is set to 'Preferred' or 'Required' and a Passphrase is not in use.

Workaround

Change the Cookie Persistence Encryption setting back to the preferred value.

Fix Information

None

Behavior Change