Bug ID 515416: FastL4 profile cannot be used on 5000 and 7000-series platforms licensed for APM only

Last Modified: Mar 12, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP APM(all modules)

Known Affected Versions:
11.5.1, 11.5.1 HF1, 11.5.1 HF10, 11.5.1 HF11, 11.5.1 HF2, 11.5.1 HF3, 11.5.1 HF4, 11.5.1 HF5, 11.5.1 HF6, 11.5.1 HF7, 11.5.1 HF8, 11.5.1 HF9, 11.5.2, 11.5.2 HF1, 11.5.3, 11.5.3 HF1, 11.5.3 HF2, 11.5.4, 11.5.4 HF1, 11.5.4 HF2, 11.5.4 HF3, 11.5.4 HF4, 11.5.5, 11.5.6, 11.5.7, 11.5.8, 11.5.9

Opened: Mar 31, 2015
Severity: 1-Blocking

Symptoms

On the 5000 and 7000-series platforms, APM standalone licenses potentially do not provide the needed license information for usage of the FastL4 feature. Upon attempts to use the profile, the user will be presented with the following error. 01020036:3: The requested profile (/Common/fastL4) was not found.

Impact

Creation and usage of a FastL4 profile will be prohibited by TMOS. Configuration using FastL4 will fail to load.

Conditions

1. The only module listed as licensed in /config/bigip.license is 'mod_apm' 2. The platform is in the 5000 or 7000 series. 3. The feature ltm_proxy_fastl4 does not appear in 'tmsh show sys license detail'.

Workaround

Renew the current license using any of the available commands, such as 'tmsh install sys license'. This will retrieve an updated license file from F5 which contains the needed licensing data.

Fix Information

None

Behavior Change