Bug ID 516307: Multiple Relay in DHCP relay is not working.

Last Modified: Sep 13, 2023

Affected Product(s):
BIG-IP LTM(all modules)

Known Affected Versions:
11.6.0, 11.6.1, 11.6.2, 11.6.3, 11.6.3.1, 11.6.3.2, 11.6.3.3, 11.6.3.4, 11.6.4, 11.6.5, 11.6.5.1, 11.6.5.2, 11.6.5.3, 12.0.0, 12.0.0 HF1, 12.1.0 HF1, 12.0.0 HF2, 12.1.0 HF2, 12.0.0 HF3, 12.0.0 HF4, 12.1.1 HF1, 12.1.1 HF2, 12.1.2 HF1, 12.1.2 HF2, 12.1.0, 12.1.1, 12.1.2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 12.1.5.1, 12.1.5.2, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1

Fixed In:
13.1.0, 12.1.5.3

Opened: Apr 03, 2015

Severity: 3-Major

Related Article: K35152864

Symptoms

If the BIG-IP is behind another DHCP relay, then the packets are not sent to the server, instead they are dropped.

Impact

This previously worked on v11.4.x, so if you are running on version 11.4.x and upgrade to 11.6.x, the virtual server may not function correctly.

Conditions

This occurs when a DHCP virtual server is configured with a profile based on dhcpv4_fwd.

Workaround

To work around this, do the following: 1. Configure a unicast IP address for the BIG-IP DHCPv4 listener destination address field. 2. Configure the same IP address as the DHCP server IP address on DHCP relay agent. This way the BIG-IP system can load balance DHCP load on to a pool of DHCP servers.

Fix Information

Multiple Relay in DHCP relay is now working.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips