Bug ID 517178: BIG-IP system as SAML Service Provider cannot process some messages from SimpleSAMLphp under certain conditions

Last Modified: Aug 19, 2026

Affected Product(s):
BIG-IP APM(all modules)

Known Affected Versions:
11.6.0, 11.6.0 hf1, 11.6.0 hf2, 11.6.0 hf3, 11.6.0 hf4, 11.6.0 hf5, 11.6.0 hf6, 11.6.0 hf7, 11.6.0 hf8, 11.6.1, 11.6.1 hf1, 11.6.1 hf2, 11.6.2, 11.6.2 hf1, 11.6.3, 11.6.3.1, 11.6.3.2, 11.6.3.3, 11.6.3.4, 11.6.4, 11.6.5, 11.6.5.1, 11.6.5.2, 11.6.5.3

Fixed In:
12.0.0

Opened: Apr 08, 2015

Severity: 3-Major

Related Article: K29660332

Symptoms

When the BIG-IP system is used as Service Provider with SimpleSAMLphp as Identity Provider, processing of signed artifact response messages from IdP may fail with following error: Digest of SignedInfo mismatch.

Impact

User SSO may not work.

Conditions

- BIG-IP system is configured as SP. - Artifact binding is used for SSO. - Artifact response message from IdP is signed.

Workaround

Use POST binding instead of Artifact.

Fix Information

The BIG-IP system configured as SAML Service Provider can now correctly process messages from SimpleSAMLphp so that user SSL works as expected.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips