Bug ID 521491: Edge Client uses a very old browser User agent string

Last Modified: Apr 10, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP APM(all modules)

Known Affected Versions:
11.4.1

Fixed In:
12.1.0

Opened: May 05, 2015
Severity: 5-Cosmetic

Symptoms

When downloading from BIG-IP 12 and earlier reports a user agent string that corresponds to IE 5.0. Customers have reported problems with firewalls not accepting User Agent strings from this very old version of IE.

Impact

Can't pass customer firewall rules from 3rd party firewalls that are set to not allow IE 5 as a browser.

Conditions

This occurs on Edge client downloaded from BIG-IP v12 and earlier.

Workaround

None

Fix Information

Adjusted User agent string to report as Internet Explorer 10. This will allow access through firewalls that don't allow old user agent strings to pass.

Behavior Change