Bug ID 523527: Upgrade from 10.x to 11.2.0 or later does not add existing routing protocols to RD0.

Last Modified: Apr 10, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP All, Install/Upgrade(all modules)

Known Affected Versions:
10.2.4, 11.2.0, 11.2.1, 11.3.0, 11.4.0, 11.4.1, 11.5.0, 11.5.1, 11.5.1 HF1, 11.5.1 HF10, 11.5.1 HF11, 11.5.1 HF2, 11.5.1 HF3, 11.5.1 HF4, 11.5.1 HF5, 11.5.1 HF6, 11.5.1 HF7, 11.5.1 HF8, 11.5.1 HF9, 11.5.2, 11.5.2 HF1, 11.5.3, 11.5.3 HF1, 11.5.3 HF2, 11.6.0, 11.6.0 HF1, 11.6.0 HF2, 11.6.0 HF3, 11.6.0 HF4, 11.6.0 HF5, 11.6.0 HF6, 11.6.0 HF7, 11.6.0 HF8, 11.6.1, 11.6.1 HF1

Fixed In:
12.0.0, 11.6.1 HF2, 11.5.4

Opened: May 15, 2015
Severity: 3-Major
Related AskF5 Article:
K43121346

Symptoms

If you are directly upgrading from version 10.x to version 11.2.0 or later with a working dynamic routing protocols configuration may encounter that the routing protocol is disabled on upgrade to 11.2.0 or later.

Impact

Routing protocol information is missing from RD0, ZebOS is not running (although configured).

Conditions

- Upgrade from 10.x to 11.2.0 or later. - Routing protocol enabled in tmrouted dbkeys. - No route domain 0 (zero) (RD0) configuration, that is defaults of all VLANs in RD0, no comment, leading to no existing configuration in bigip_base.conf

Workaround

There are several workarounds to this issue: - Causing the RD0 configuration to exist by adding a comment to the 10.x description field and saving prior to upgrade. - Re-adding the routing protocol to the RD0 configuration after the upgrade. - Perform an intermediate upgrade from 10.x to 11.0.0 or 11.1.0 prior to upgrading to an 11.2.0 or later version.

Fix Information

Routing protocols are now correctly configured on Route Domain 0 (zero) (RD0) after upgrade to version 11.2.0 or later.

Behavior Change