Bug ID 525708: AVR reports of last year are missing the last month data

Last Modified: Feb 13, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP AFM, APM, ASM, AVR, CGN, GTM, PEM, PSM, SWG, vCMP(all modules)

Known Affected Versions:
11.5.1, 11.5.1 HF1, 11.5.1 HF10, 11.5.1 HF11, 11.5.1 HF2, 11.5.1 HF3, 11.5.1 HF4, 11.5.1 HF5, 11.5.1 HF6, 11.5.1 HF7, 11.5.1 HF8, 11.5.1 HF9, 11.5.2, 11.5.2 HF1, 11.5.3, 11.5.3 HF1, 11.6.0, 11.6.0 HF1, 11.6.0 HF2, 11.6.0 HF3, 11.6.0 HF4, 11.6.0 HF5, 12.0.0

Fixed In:
12.1.0, 12.0.0 HF1, 11.6.0 HF6, 11.5.3 HF2

Opened: May 29, 2015
Severity: 3-Major
Related AskF5 Article:
K17555

Symptoms

Reports are missing the latest data collected for them. Each report-type is missing a different portion of the data which is relative to the report-type. This issue becomes very noticeable when creating long-term reports. For example, a 'last-year' report might omit the last month data, 'last-month' report might omit the last week data, and so on.

Impact

The presented data can be confusing and misleading.

Conditions

Every report that is done on a long history time range.

Workaround

None

Fix Information

A new data aggregation mechanism was inserted, so that all reports include activity up to the last hour. There is an option to make it available even for the last 5 minutes, although that might lead to too much CPU and disk load every 5 minutes. There is also an option to turn off this new aggregation mechanism if you are not interested in accurate long-history reports, and the aggregation task that takes place once an hour is too heavy for this machine.

Behavior Change