Bug ID 527080: Upgrade of invalid IP address or FQDN configuration.

Last Modified: Mar 21, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP Install/Upgrade, LTM(all modules)

Known Affected Versions:
11.6.0, 11.6.0 HF1, 11.6.0 HF2, 11.6.0 HF3, 11.6.0 HF4, 11.6.0 HF5, 11.6.0 HF6, 11.6.0 HF7, 11.6.0 HF8, 11.6.1, 11.6.1 HF1, 11.6.1 HF2, 11.6.2, 11.6.2 HF1, 11.6.3, 11.6.3.1, 11.6.3.2, 11.6.3.3, 11.6.3.4, 11.6.4

Opened: Jun 09, 2015
Severity: 2-Critical

Symptoms

All nodes must have unique constraints on IP address or FQDN. If a saved configuration has violated that constraint, the upgrade fails when the configuration fails validation.

Impact

Configuration fails to load on upgrade. The system posts messages similar to the following in the ltm log: ltm log: -- err tmsh[9336]: 01420006:3: Loading configuration process failed. -- emerg load_config_files: '/usr/bin/tmsh -n -g load sys config partitions all' - failed. -- 01070734:3: Configuration error: Invalid FQDN : the node already exists for (www.siterequest.com) Unexpected Error: Loading configuration process failed. -- err mcpd[7634]: 01070425:3: Full configuration load failed.

Conditions

Configuration contains nodes that do not have unique IP addresses or FQDNs.

Workaround

Delete duplicate IP addresses or FQDNs and retry the upgrade/load.

Fix Information

None

Behavior Change