Bug ID 551661: Monitor with send/receive string containing double-quote may fail to load.

Last Modified: Aug 19, 2026

Affected Product(s):
BIG-IP All(all modules)

Known Affected Versions:
11.5.4, 11.5.4 hf1, 11.5.4 hf2, 11.5.4 hf3, 11.5.4 hf4, 11.5.5, 11.5.6, 11.5.7, 11.5.8, 11.5.9, 11.5.10, 11.6.0, 11.6.0 hf1, 11.6.0 hf2, 11.6.0 hf3, 11.6.0 hf4, 11.6.0 hf5, 11.6.0 hf6, 11.6.0 hf7, 11.6.0 hf8, 12.0.0, 12.0.0 hf1, 12.0.0 hf2, 12.0.0 hf3, 12.0.0 hf4

Fixed In:
12.1.0, 11.6.1

Opened: Oct 09, 2015

Severity: 2-Critical

Related Article: K41214270

Symptoms

When a monitor string contains contains \" (backslash double-quote) but does not contain a character that requires quoting, one level of escaping is lost at each save/load. Note: Re-loading a config happens during licensing. If you decide to upgrade, first verify that you have an escaped quote in the monitor string. If you do, remove the re-licensing step from your MOP (Method of Procedure). The failure message for reloading the license with an escaped quote appears similar to the following example: Monitor monitor_1 parameter contains unescaped " escape with backslash.

Impact

Monitors are marked down due to expected string not matching or incorrect send string. Potential load failure.

Conditions

If the string contains \" (backslash double-quote) but does not contain one of the following characters: ' (single quote), | (pipe), { (open brace), } (close brace), ; (semicolon), # (hashtag), literal newline, or literal space.

Workaround

You can use either of the following workarounds: -- Modify the content the BIG-IP system retrieves from the web server for the purposes of health monitoring, so that double quotes are not necessary. -- Use an external monitor instead.

Fix Information

If the monitor send-recv strings contain a double-quote ", character, the system now adds quotes to the input. If a configuration contains '/"', does not reload the license before upgrade.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips