Bug ID 555356: Use of unsupported options with racoonctl utility causes racoon to crash.

Last Modified: Jan 16, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP LTM(all modules)

Known Affected Versions:
11.6.0, 11.6.0 HF1, 11.6.0 HF2, 11.6.0 HF3, 11.6.0 HF4, 11.6.0 HF5, 11.6.0 HF6, 11.6.0 HF7, 11.6.0 HF8, 11.6.1, 11.6.1 HF1, 11.6.1 HF2, 11.6.2, 11.6.2 HF1, 11.6.3, 11.6.3.1, 11.6.3.2, 11.6.3.3, 11.6.3.4, 12.0.0, 12.0.0 HF1, 12.0.0 HF2, 12.0.0 HF3, 12.0.0 HF4

Fixed In:
12.1.0

Opened: Oct 30, 2015
Severity: 4-Minor

Symptoms

Racoon may crash if unsupported options like 'reload-config', 'establish-sa', and 'vpn-connect'are used with racoonctl utility. These options are not currently supported in BIG-IP.

Impact

The racoon utility crashes.

Conditions

Racoon may crash if unsupported options such as 'reload-config', 'establish-sa', and 'vpn-connect' are used with racoonctl utility.

Workaround

Use other supported options with racoonctl utility to delete or list the security associations.

Fix Information

Unsupported command options (such as 'reload-config', 'establish-sa', and 'vpn-connect') are now removed from the racoonctl utility.

Behavior Change