Bug ID 555380: "Data publisher not found or not implemented" messages in ltm log when running qkview

Last Modified: Mar 12, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP TMOS(all modules)

Known Affected Versions:
11.5.1, 11.5.1 HF1, 11.5.1 HF10, 11.5.1 HF11, 11.5.1 HF2, 11.5.1 HF3, 11.5.1 HF4, 11.5.1 HF5, 11.5.1 HF6, 11.5.1 HF7, 11.5.1 HF8, 11.5.1 HF9, 11.5.2, 11.5.2 HF1, 11.5.3, 11.5.3 HF1, 11.5.3 HF2, 11.5.4, 11.5.4 HF1, 11.5.4 HF2, 11.5.4 HF3, 11.5.4 HF4, 11.5.5, 11.5.6, 11.5.7, 11.5.8, 11.5.9, 12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4

Fixed In:
13.0.0

Opened: Oct 30, 2015
Severity: 5-Cosmetic

Symptoms

When running a qkview, there are various "Data publisher not found or not implemented" messages in /var/log/ltm. This is benign and these messages can be safely ignored. The items are related to psu, cooling and chassis info.

Impact

A bit of concern by anybody monitoring /var/log/ltm and seeing these messages during a qkview which shouldn't have discernible impact on a system.

Conditions

Always present since the query is always made for these items that aren't available.

Workaround

Ignore the messages as they are not caused by anything wrong in the system.

Fix Information

Removed items from qkview, thus eliminating the messages. One still remains if there are various blades in a chassis caused "show sys memory" on the individual blade. A separate bug for this has been filed (bug 567330).

Behavior Change