Bug ID 598134: Stats query may generate an error when tmm on secondary is down

Last Modified: Aug 19, 2026

Affected Product(s):
BIG-IP TMOS(all modules)

Known Affected Versions:
12.0.0, 12.0.0 hf1, 12.0.0 hf2, 12.0.0 hf3, 12.0.0 hf4, 12.1.0, 12.1.0 hf1, 12.1.0 hf2, 12.1.1, 12.1.1 hf1, 12.1.1 hf2, 12.1.2, 12.1.2 hf1, 12.1.2 hf2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 12.1.5.1, 12.1.5.2, 12.1.5.3, 12.1.6

Fixed In:
13.0.0

Opened: Jun 08, 2016

Severity: 3-Major

Symptoms

Querying for stats results in an error and further iControl messages are incorrect.

Impact

The iControl session must be restarted.

Conditions

Must be on a chassis. The query must be for stats generated by tmm. A secondary tmm must be down.

Workaround

Ensure all tmms are up and running.

Fix Information

The request is handled appropriately even if a tmm is down and no unexpected error is generated.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips