Bug ID 630062: gnome-software throws error "This file is not supported" for F5EPI and F5VPN RPMs on Fedora 25

Last Modified: Jul 12, 2023

Affected Product(s):
BIG-IP APM(all modules)

Known Affected Versions:
13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.0.1.1

Fixed In:
13.1.0

Opened: Nov 23, 2016

Severity: 2-Critical

Symptoms

gnome-software returns the error <systemoutput>This file is not supported</systemoutput> for F5VPN and F5EPI RPMs on Fedora 25.

Impact

F5EPI and F5VPN applications cannot be installed using OS native software installer GUI.

Conditions

gnome-software, F5EPI and F5VPN RPM. This is specific to Fedora 25 and gnome-software version 3.22.1.

Workaround

As a workaround, open the Terminal application. From the command line run either of the following commands:<p>- pkgcon install-local -y -n /path/to/rpm/package. </p><p>- dnf install /path/to/rpm/package</p>

Fix Information

Versions of gnome-software 3.22.5 and later can now install F5EPI and F5VPN helper applications successfully.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips