Bug ID 632726: HA in AWS across AZs fails; posts aws-parse-network-description error messages

Last Modified: May 01, 2019

Bug Tracker

Affected Product:  See more info
iApps All(all modules)

Known Affected Versions:
12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5

Opened: Dec 09, 2016
Severity: 2-Critical

Symptoms

Configuring high availability (HA) fails in Amazon Web Services (AWS) across Availability Zones (AZs). The system posts aws-parse-network-description error messages in /var/log/ltm similar to the following: -- notice logger: /usr/libexec/aws/aws-failover-tgactive.sh (traffic-group-1): Started. ... -- debug aws_advanced_failover: command: /usr/libexec/aws/aws-parse-network-description -i i-76e03061 -p 10.0.2.229 -f /tmp/tmppvI76L ended with status 2 had stdout: Unable to locate subnet for IP 10.0.2.229. and stderr: -- err aws_advanced_failover: Failed command: "/usr/libexec/aws/aws-parse-network-description -i i-76e03061 -p 10.0.2.229 -f /tmp/tmppvI76L" Check to make sure secondary address exists on target ENI -- debug aws_advanced_failover: ENI is Unable to locate subnet for IP 10.0.2.229. -- err aws_advanced_failover: Could not transfer EIP 34.192.173.143 ...

Impact

The HA configuration across AZs fails.

Conditions

This occurs when the following conditions are met: -- Configuring HA in AWS across AZs. -- Using BIG-IP Virtual Edition (VE). -- Using a version of the AWS Advanced HA failover iApp earlier than f5.aws_advanced_ha.v1.4.0rc2.tmpl.

Workaround

None.

Fix Information

None

Behavior Change