Bug ID 643547: APMD initialization may fail when large number of access policy agents are configured in access policies installed on BIG-IP

Last Modified: Aug 19, 2026

Affected Product(s):
BIG-IP APM(all modules)

Known Affected Versions:
12.1.0, 12.1.0 hf1, 12.1.0 hf2, 12.1.1, 12.1.1 hf1, 12.1.1 hf2, 12.1.2, 12.1.2 hf1, 12.1.2 hf2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 12.1.5.1, 12.1.5.2, 12.1.5.3, 12.1.6, 13.0.0, 13.0.0 hf1, 13.0.0 hf2, 13.0.0 hf3, 13.0.1

Fixed In:
13.1.0

Opened: Feb 06, 2017

Severity: 3-Major

Related Article: K43036745

Symptoms

Requests to /my.policy are not getting HTTP responses. Log file '/var/log/apm' contains large number of error messages about failed XML data creation: err apmd[5076]: 01490207:3: SAML Agent XML thread specific data creation error: ERR_FAIL.

Impact

APMD will not able to process any requests.

Conditions

This issue occurs when all of the following conditions are met: -- Your BIG-IP APM system is configured with a large number of access policy agents. -- You are performing an operation that requires the apmd process to start. -- For example, your BIG-IP APM system is reloaded, you install a new image, or you manually restart the apmd process.

Workaround

For some configurations and platforms, you can use the following steps to recover: - Remove all unused access policies (if applicable). - Restart apmd.

Fix Information

Now APMD initialization will no longer fail at XML initialization when a large number of access policies/agents are present in the configuration.

Behavior Change

Guides & references

K10134038: F5 Bug Tracker Filter Names and Tips