Bug ID 651005: FTP data connection may use incorrect auto-lasthop settings.

Last Modified: Apr 10, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP LTM(all modules)

Known Affected Versions:
11.5.1, 11.5.1 HF1, 11.5.1 HF10, 11.5.1 HF11, 11.5.1 HF2, 11.5.1 HF3, 11.5.1 HF4, 11.5.1 HF5, 11.5.1 HF6, 11.5.1 HF7, 11.5.1 HF8, 11.5.1 HF9, 11.5.2, 11.5.2 HF1, 11.5.3, 11.5.3 HF1, 11.5.3 HF2, 11.5.4, 11.5.4 HF1, 11.5.4 HF2, 11.5.4 HF3, 11.5.4 HF4, 11.5.5, 11.5.6, 11.5.7, 11.5.8, 11.5.9, 11.6.0, 11.6.0 HF1, 11.6.0 HF2, 11.6.0 HF3, 11.6.0 HF4, 11.6.0 HF5, 11.6.0 HF6, 11.6.0 HF7, 11.6.0 HF8, 11.6.1, 11.6.1 HF1, 11.6.1 HF2, 11.6.2, 11.6.2 HF1, 11.6.3, 11.6.3.1, 11.6.3.2, 11.6.3.3, 11.6.3.4, 11.6.4, 12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1

Fixed In:
13.1.0

Opened: Mar 13, 2017
Severity: 4-Minor

Symptoms

Due to known issue FTP data connection may fail to use auto-lasthop settings configured on the virtual server and use a value configured on VLAN level instead.

Impact

FTP data connection may fail to be established.

Conditions

With the configuration below, FTP data connection will fail to use auto-lasthop: (1) - Global auto-lasthop set to 'disable' - VLAN auto-lasthop set to 'default' - Virtual server auto-lasthop set to 'enable' (2) - Global auto-lasthop set to 'disable' - VLAN auto-lasthop set to 'disable' - Virtual server auto-lasthop set to 'enable' With the configuration below, FTP data connection will improperly use the auto-lasthop: (1) - Global auto-lasthop set to 'enable' - VLAN auto-lasthop set to 'default' - Virtual server auto-lasthop set to 'disable' (2) - VLAN auto-lasthop set to 'enable' - Virtual server auto-lasthop set to 'disable'

Workaround

Use routing instead of auto-lasthop. (or) Enable auto-lasthop on VLAN level.

Fix Information

None

Behavior Change