Bug ID 671518: F5 does not currently support i18n across its product lines.

Last Modified: Sep 06, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP All(all modules)

Known Affected Versions:
12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.4, 14.1.0.5, 14.1.0.6, 14.1.2

Opened: Jun 28, 2017
Severity: 3-Major

Symptoms

APIs and interfaces at F5 have varying levels of support for Unicode and extended character sets. There is currently no comprehensive solution for non-ASCII support. Any non-ASCII data is not strictly guaranteed to behave or display as expected.

Impact

All APIs and interfaces are not guaranteed to support non-ASCII characters.

Conditions

Non-ASCII character sets are used in resource configuration across the F5 product line.

Workaround

There is no workaround at this time. Different interfaces at F5 have varying levels of support for non-ASCII text, though none have support officially.

Fix Information

None

Behavior Change