Bug ID 677428: While upgrading a BIG-IP HA pair to version 13.1.0, mirroring may not work while the units are running different software versions

Last Modified: Jan 20, 2023

Bug Tracker

Affected Product:  See more info
BIG-IP All(all modules)

Known Affected Versions:
13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 13.1.3.1, 13.1.3.2, 13.1.3.3, 13.1.3.4, 13.1.3.5, 13.1.3.6, 13.1.4, 13.1.4.1, 13.1.5, 13.1.5.1, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.0.1.1, 14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 14.1.2.5, 14.1.2.6, 14.1.2.7, 14.1.2.8, 14.1.3, 14.1.3.1, 14.1.4, 14.1.4.1, 14.1.4.2, 14.1.4.3, 14.1.4.4, 14.1.4.5, 14.1.4.6, 14.1.5, 14.1.5.1, 14.1.5.2, 14.1.5.3

Opened: Aug 08, 2017
Severity: 4-Minor

Symptoms

As part of upgrading a BIG-IP high availability (HA) configuration to version 13.1.0, there is a brief moment when the two units are running different software versions. For instance, the unit that was upgraded first will be running version 13.1.0, while the peers may still be running the previous software version (such as 13.0.0). During this time, mirroring (Connection Mirroring, Persistence Mirroring, and Session Mirroring) may not be working, and errors similar to the following example may be logged to the /var/log/ltm file: -- err tmm3[17095]: 01340004:3: HA Connection detected dissimilar peer: local npgs 1, remote npgs 1, local npus 4, remote npus 4, local pg 0, remote pg 0, local pu 3, remote pu 0. Connection will be aborted. -- err tmm2[17095]: 01340004:3: HA Connection detected dissimilar peer: local npgs 1, remote npgs 1, local npus 4, remote npus 4, local pg 0, remote pg 0, local pu 2, remote pu 1. Connection will be aborted. This issue occurs because of differences in the hashing of traffic by the pre-13.1.0 and post-13.1.0 Virtual Edition (VE) NIC drivers.

Impact

Mirroring does not work until the upgrade is completed and each unit is running version 13.1.0. During this time, failing over between the units can result in the loss of connection, persistence, or session records. Please note mirroring support is only considered best-effort while the units are running different software versions as part of a software upgrade.

Conditions

- A BIG-IP HA pair is upgraded to version 13.1.0 from a previous version. - The BIG-IP HA configuration consists of VE units (all other platforms are not affected).

Workaround

There is no workaround.

Fix Information

None

Behavior Change