Bug ID 722618: New Chrome version is blocked when using Proactive Bot Defense

Last Modified: May 07, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP ASM(all modules)

Fixed In:
14.1.0, 14.0.0

Opened: Jun 01, 2018
Severity: 3-Major

Symptoms

Mozilla Chrome versions 67 and later, selenium is false-detected. The system posts a message similar to the following: -- info tmm1[24434]: Rule /Common/UBOT_PRINT <BOTDEFENSE_ACTION>: client_anomaly {Selenium WebDriver Detected}.

Impact

Legitimate users using Chrome 67 and later might get blocked/captcha.

Conditions

-- Proactive Bot Defense. -- Block suspicious browsers is enabled.

Workaround

None.

Fix Information

This version fixes the selenium test for new Chrome versions.

Behavior Change