Bug ID 740133: cmp_dest --command resolve with --platform option but without --opaque_data option produces incorrect results.

Last Modified: Nov 07, 2022

Bug Tracker

Affected Product:  See more info
BIG-IP TMOS(all modules)

Known Affected Versions:
12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 12.1.5.1, 12.1.5.2, 12.1.5.3, 12.1.6, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 13.1.3.1, 13.1.3.2, 13.1.3.3, 13.1.3.4, 13.1.3.5, 13.1.3.6, 13.1.4, 13.1.4.1, 13.1.5, 13.1.5.1, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.0.1.1

Fixed In:
14.1.0

Opened: Aug 13, 2018
Severity: 4-Minor

Symptoms

Using cmp_dest --command resolve with --platform option but without the --opaque_data option produces incorrect results.

Impact

Incorrect results for cmp_dest resolve command.

Conditions

-- The DAG hash is P8DAG (you can check by running the following command: tmctl -d blade tmm/daglib). -- The platform option is used -- The opaque_data option is not used, so cmp_dest uses cmp_state to infer it.

Workaround

Explicitly provide opaque_data option.

Fix Information

Now, running the cmp_dest --command resolve and including the --platform option without the --opaque_data option produces correct results.

Behavior Change