Bug ID 745707: Portal Access Web Page does not render properly

Last Modified: Jul 03, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP APM(all modules)

Known Affected Versions:
12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.4, 14.1.0.5, 14.1.0.6

Fixed In:
15.0.0

Opened: Oct 02, 2018
Severity: 3-Major

Symptoms

Some of the Microsoft hosted cloud sites, including dynamics, use a logon process that goes through secure.aadcdn.microsoftonline-p.com. This might result in a number of different kinds of problems: -- iOS devices do not send the MRHSession cookie, so are denied when requesting CSS and JavaScript. -- Android devices might 'fail to load'.

Impact

-- The PA Web Page does not load correctly. -- Script errors appear on the browser console. -- Intended functionality on the web page is not provided.

Conditions

Using Portal Access (PA) on a Microsoft-hosted cloud site.

Workaround

You can use an iRule to work around this.

Fix Information

Portal Access Web Page now renders properly under these conditions.

Behavior Change