Bug ID 745825: The "audit_forwarder is disabled as the configuration is incomplete" message can be confusing if logged when the configuration is loading

Last Modified: Nov 07, 2022

Bug Tracker

Affected Product:  See more info
BIG-IP LTM(all modules)

Known Affected Versions:
13.0.0, 13.0.0 HF1, 13.0.0 HF2, 13.0.0 HF3, 13.0.1, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 13.1.3.1, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.0.1.1, 14.1.0, 14.1.0.1

Fixed In:
15.0.0, 14.1.0.2, 13.1.3.2

Opened: Oct 03, 2018
Severity: 3-Major

Symptoms

This message may be logged while the audit_forwarder is loading the configuration: audit_forwarder is disabled as the configuration is incomplete. Please define the following db variables: config.auditing.forward.sharedsecret, config.auditing.forward.destination and config.auditing.forward.type. And make sure config.auditing.forward.destination is not set to "::". These DB variables may all be actually configured correctly, but since the configuration has not loaded yet this message may be logged multiple times.

Impact

Confusing error messages in /var/log/ltm. Logging will still work as configured.

Conditions

The audit_forwarder process is starting up and loading the configuration.

Workaround

There is no workaround.

Fix Information

Message has been modified to indicate the possibility of loading the configuration. Message is now logged only once. A new messages is logged indicating when audit_forwarder is enabled.

Behavior Change