Bug ID 749477: Provisioning URLDB and SWG simultaneously produces a confusing error message if neither module was originally provisioned

Last Modified: Nov 22, 2021

Bug Tracker

Affected Product:  See more info
BIG-IP SWG(all modules)

Fixed In:
15.0.0

Opened: Nov 12, 2018
Severity: 3-Major

Symptoms

If you have URLDB or SWG provisioned and try to provision the other, you will get an error message: The requested provision module (%s) is not compatible with already provisioned module (%s). This same error message is displayed if neither module was provisioned to start with, and can be confusing.

Impact

You can safely ignore the benign error message.

Conditions

Attempt to provision SWG and URLDB without either module being originally provisioned

Workaround

None.

Fix Information

New message makes sense regardless of the starting state (i.e. SWG or URLB or neither originally provisioned): Module (%s) is not compatible with module (%s). These modules can't be provisioned simultaneously.

Behavior Change