Bug ID 758879: BIG-IP VE with ixlv devices does not reliably pass some traffic after hard-boot

Last Modified: May 23, 2019

Bug Tracker

Affected Product:  See more info
BIG-IP All(all modules)

Known Affected Versions:
14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.4, 14.1.0.5

Fixed In:
15.0.0

Opened: Feb 15, 2019
Severity: 3-Major

Symptoms

BIG-IP Virtual Edition (VE) with ixlv devices (Intel X710/XL710/XXV710 family) might not reliably pass traffic after a hard boot of the host on which it runs. The tmm log contains messages similar to the following: ixlv[0:8.0]: Error: AQ returned error -1 to request 10! ixlv[0:8.0]: Error: Error -1 waiting for PF to complete operation 4 ixlv[0:8.0]: Error: WARNING: Error adding VF mac filter! ixlv[0:8.0]: Error: WARNING: Device may not receive traffic! The host's kernel log might contain messages similar to the following: i40e 0000:06:00.0: VF is not trusted, switch the VF to trusted to add more functionality

Impact

IPv6 and other network traffic may be handled unreliably.

Conditions

-- BIG-IP VE with one or more virtual functions that utilize the ixlv driver within tmm. -- Hard reboot the host and observe traffic. Note: This issue might be dependent upon the version of the PF driver in the host, and has been observed with at least 2.1.4 and 2.4.10, but this list is incomplete.

Workaround

Reboot the guest. This problem has been observed only on the very first boot after a hard boot of the host.

Fix Information

None

Behavior Change