Bug ID 850673: BD sends bad ACKs to the bd_agent for configuration

Last Modified: Jul 22, 2021

Bug Tracker

Affected Product:  See more info
BIG-IP ASM(all modules)

Known Affected Versions:
12.1.0, 12.1.0 HF1, 12.1.0 HF2, 12.1.1, 12.1.1 HF1, 12.1.1 HF2, 12.1.2, 12.1.2 HF1, 12.1.2 HF2, 12.1.3, 12.1.3.1, 12.1.3.2, 12.1.3.3, 12.1.3.4, 12.1.3.5, 12.1.3.6, 12.1.3.7, 12.1.4, 12.1.4.1, 12.1.5, 13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 13.1.3.1, 13.1.3.2, 13.1.3.3, 14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 15.0.0, 15.0.1, 15.0.1.1, 15.0.1.2, 15.1.0, 15.1.0.1

Fixed In:
16.0.0, 15.1.0.2, 15.0.1.3, 14.1.2.5, 13.1.3.4, 12.1.5.1

Opened: Nov 17, 2019
Severity: 3-Major

Symptoms

-- The bd_agents stops sending the configuration in the middle of startup or a configuration change. -- The policy may be incomplete in the bd causing incorrect enforcement actions.

Impact

-- The bd_agent hangs or restarts, which may cause a complete ASM restart (and failover). -- A partial policy may exist in bd causing improper enforcement.

Conditions

This is a rarely occurring issue, and the exact conditions that trigger it are unknown.

Workaround

-- Unassign and reassign the policy. -- if unassign/reassign does not help, export and then reimport the policy.

Fix Information

Fixed inconsistency scenario between bd and bd_agent.

Behavior Change