Bug ID 919581: AppManager unable to manage service-catalog applications after upgrade

Last Modified: May 03, 2021

Bug Tracker

Affected Product:  See more info
BIG-IQ Applications(all modules)

Known Affected Versions:
7.1.0, 7.1.0.1, 7.1.0.2, 7.1.0.3, 7.1.6, 7.1.6.1, 7.1.7, 7.1.7.1, 7.1.7.2, 7.1.8, 7.1.8.1, 7.1.8.2, 7.1.8.3, 7.1.8.4, 7.1.8.5, 7.1.9, 7.1.9.7, 7.1.9.8, 7.1.9.9, 8.0.0, 8.0.0.1

Opened: Jun 19, 2020
Severity: 3-Major

Symptoms

A BIG-IQ user with AppManager & AppServiceManager permission encounters the following error while trying to open the app: You are not authorized for appsvcsschemastate.

Impact

User with AppManager & AppServiceManager role is unable to manage the service catalog applications.

Conditions

BIG-IQ is upgraded from 6.1 to a newer version of BIG-IQ namely 7.0.x, 7.1.0.x, and 8.0.0

Workaround

These apps are manageable by admins. A workaround is to elevate an AppManager & AppServiceManager user to an admin.

Fix Information

None

Behavior Change