Bug ID 928177: Syn-cookies might get enabled when performing multiple software upgrades.

Last Modified: Oct 14, 2020

Bug Tracker

Affected Product:  See more info
BIG-IP AFM(all modules)

Known Affected Versions:
14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 14.1.2.5, 14.1.2.6, 14.1.2.7, 14.1.2.8, 15.0.0, 15.0.1, 15.0.1.1, 15.0.1.2, 15.0.1.3, 15.0.1.4, 15.1.0, 15.1.0.1, 15.1.0.2, 15.1.0.3, 15.1.0.4, 15.1.0.5, 16.0.0, 16.0.0.1

Opened: Jul 17, 2020
Severity: 4-Minor

Symptoms

Syn-cookie protection of FastL4/TCP profile might get enabled when performing multiple software upgrades.

Impact

Value of profile attribute syn-cookie-enable might be changed during an upgrade.

Conditions

-- Performing an upgrade from version earlier than 14.0.0 to a version higher than or equal to 14.0.0. -- Then performing another upgrade.

Workaround

Save configuration before starting each upgrade.

Fix Information

None

Behavior Change