Bug ID 933793: Cannot configure datagroups as negate condition in LTM policy rule

Last Modified: Jul 23, 2021

Bug Tracker

Affected Product:  See more info
BIG-IP LTM(all modules)

Known Affected Versions:
13.1.0, 13.1.0.1, 13.1.0.2, 13.1.0.3, 13.1.0.4, 13.1.0.5, 13.1.0.6, 13.1.0.7, 13.1.0.8, 13.1.1, 13.1.1.2, 13.1.1.3, 13.1.1.4, 13.1.1.5, 13.1.3, 13.1.3.1, 13.1.3.2, 13.1.3.3, 13.1.3.4, 13.1.3.5, 13.1.3.6, 13.1.4, 13.1.4.1, 14.0.0, 14.0.0.1, 14.0.0.2, 14.0.0.3, 14.0.0.4, 14.0.0.5, 14.0.1, 14.0.1.1, 14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 14.1.2.5, 14.1.2.6, 14.1.2.7, 14.1.2.8, 14.1.3, 14.1.3.1, 14.1.4, 14.1.4.1, 14.1.4.2, 14.1.4.3, 15.0.0, 15.0.1, 15.0.1.1, 15.0.1.2, 15.0.1.3, 15.0.1.4, 15.1.0, 15.1.0.1, 15.1.0.2, 15.1.0.3, 15.1.0.4, 15.1.0.5, 15.1.1, 15.1.2, 15.1.2.1, 15.1.3, 15.1.3.1, 16.0.0, 16.0.0.1, 16.0.1, 16.0.1.1, 16.0.1.2, 16.1.0

Opened: Aug 05, 2020
Severity: 3-Major

Symptoms

When attempting to create/add a rule to an LTM policy with a negate condition ('is not'), datagroups are not available as an option.

Impact

Unable to create or modify an LTM policy rule that tests for the absence of datagroup-elements via the Configuration Utility.

Conditions

-- Create/add a rule to an LTM policy. -- Policy has a negate condition. -- Attempt to add datagroups as an option.

Workaround

Use TMSH to create and modify policy rules involving datagroups: modify ltm policy Drafts/test-policy rules modify { test1 { conditions add { 0 { http-uri query-string not datagroup my-dg-list } } } }

Fix Information

None

Behavior Change