Bug ID 937777: The invalid configuration of using HTTP::payload in a PEM Policy may cause the TMM to crash.

Last Modified: Sep 16, 2020

Bug Tracker

Affected Product:  See more info
BIG-IP LTM(all modules)

Known Affected Versions:
14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 14.1.2.5, 14.1.2.6, 14.1.2.7, 15.0.0, 15.0.1, 15.0.1.1, 15.0.1.2, 15.0.1.3, 15.0.1.4, 15.1.0, 15.1.0.1, 15.1.0.2, 15.1.0.3, 15.1.0.4, 15.1.0.5, 16.0.0, 16.0.0.1

Opened: Aug 18, 2020
Severity: 2-Critical

Symptoms

The iRule command HTTP::payload is not supported for use within Policy Enforcement Manager (PEM) policies. Attempting to use this within your configuration may result in the TMM crashing.

Impact

Traffic disrupted while the TMM restarts.

Conditions

-- Policy Enforcement Manager (PEM) policy containing the iRule command HTTP::payload

Workaround

Do not use the iRule command HTTP::payload within Policy Enforcement Manager (PEM) policies.

Fix Information

None

Behavior Change