Bug ID 973201: F5OS BIG-IP tenants allow OS upgrade to unsupported TMOS versions

Last Modified: Nov 07, 2022

Bug Tracker

Affected Product:  See more info
BIG-IP Install/Upgrade, TMOS(all modules)

Known Affected Versions:
14.1.0, 14.1.0.1, 14.1.0.2, 14.1.0.3, 14.1.0.5, 14.1.0.6, 14.1.2, 14.1.2.1, 14.1.2.2, 14.1.2.3, 14.1.2.4, 14.1.2.5, 14.1.2.6, 14.1.2.7, 14.1.2.8, 14.1.3, 14.1.3.1, 15.1.0, 15.1.0.1, 15.1.0.2, 15.1.0.3, 15.1.0.4, 15.1.0.5, 15.1.1, 15.1.2, 15.1.2.1, 15.1.3, 15.1.3.1

Fixed In:
16.1.0, 15.1.4, 14.1.4

Opened: Dec 11, 2020
Severity: 3-Major

Symptoms

Releases prior to BIG-IP 14.1.4 allow the installation of incompatible versions of BIG-IP software and cause the tenant to become unusable in F5OS.

Impact

Tenant is unusable when upgrading to an unsupported F5OS BIG-IP version.

Conditions

This happens when you upload an incompatible version of BIG-IP software into the F5OS BIG-IP tenant and begins a live upgrade.

Workaround

None

Fix Information

F5OS BIG-IP v14.1.4 and later prevents installation of an invalid F5OS BIG-IP version.

Behavior Change